Home > Exchange, Exchange 2010, Microsoft > Problems installing Exchange SP1

Problems installing Exchange SP1


Had a issue recently where installing Exchange as SP1 gave me the following failure on the Mailbox Role;

Summary: 3 item(s). 1 succeeded, 1 failed.
Elapsed time: 00:00:04
Preparing Setup
Completed
Elapsed Time: 00:00:00
Mailbox Role
Failed
Error:
The following error was generated when "$error.Clear();
$name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]: :DiscoveryMailboxUniqueName;
$dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]: :DiscoveryMailboxDisplayName;
$dismbx = get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1;
if( $dismbx -ne $null)
{
$srvname = $dismbx.ServerName;
if( $dismbx.Database -ne $null -and $RoleFqdnOrName -like "$srvname.*" )
{
Write-ExchangeSetupLog -info "Setup DiscoverySearchMailbox Permission.";
$mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
if( $mountedMdb -eq $null )
{
Write-ExchangeSetupLog -info "Mounting database before stamp DiscoverySearchMailbox Permission…";
mount-database $dismbx.Database;
}
$mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
if( $mountedMdb -ne $null )
{
$dmRoleGroupGuid = [Microsoft.Exchange.Data.Directory.Management.RoleGroup]:: DiscoveryManagementWkGuid;
$dmRoleGroup = Get-RoleGroup -Identity $dmRoleGroupGuid -DomainController $RoleDomainController -ErrorAction:SilentlyContinue;
if( $dmRoleGroup -ne $null )
{
Add-MailboxPermission $dismbx -User $dmRoleGroup.Identity -AccessRights FullAccess -DomainController $RoleDomainController -WarningAction SilentlyContinue;
}
}
}
}
" was run: "Couldn’t mount the database that you specified. Specified database: Mailbox Database 0688175257; Error code: An Active Manager operation failed with a transient error. Please retry the operation. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: An error occurred while preparing to mount database ‘Mailbox Database 0688175257’. Error: Could not find a part of the path ‘E:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database 0688175257’. [Database: Mailbox Database 0688175257, Server: ELKINS.COMPANYAD.dom].".
Couldn’t mount the database that you specified. Specified database: Mailbox Database 0688175257; Error code: An Active Manager operation failed with a transient error. Please retry the operation. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: An error occurred while preparing to mount database ‘Mailbox Database 0688175257’. Error: Could not find a part of the path ‘E:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database 0688175257’. [Database: Mailbox Database 0688175257, Server: ELKINS.COMPANYAD.dom].
An Active Manager operation failed with a transient error. Please retry the operation. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: An error occurred while preparing to mount database ‘Mailbox Database 0688175257’. Error: Could not find a part of the path ‘E:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database 0688175257’. [Database: Mailbox Database 0688175257, Server: ELKINS.COMPANYAD.dom]
An Active Manager operation failed with a transient error. Please retry the operation. Error: An error occurred while preparing to mount database ‘Mailbox Database 0688175257’. Error: Could not find a part of the path ‘E:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database 0688175257’. [Server: Elkins.COMPANYAD.dom]
An error occurred while preparing to mount database ‘Mailbox Database 0688175257’. Error: Could not find a part of the path ‘E:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database 0688175257’.
Could not find a part of the path ‘E:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database 0688175257’.
Click here for help… http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex88D115&l=0&cl=cp
Elapsed Time: 00:00:03
Finalizing Setup
Cancelled

The problem was that it couldn’t create the “’E:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database 0688175257” folder. I re-created it by hand, and re-run the Mailbox role deployment and it all worked fine!

Advertisements
  1. Craig
    March 3, 2011 at 2:50 am

    I just had the same problem. The answer is so obvious after I read this 🙂

  2. Chris
    July 12, 2011 at 8:06 pm

    Legend. Exactly the same problem with the mailbox role, installed successfully after finally creating that missing Mailbox folder.

    THANK YOU!!

  3. Nik
    November 30, 2011 at 3:17 pm

    Just had the same problem, this solved it. Thanks

  4. kev
    May 18, 2012 at 10:16 am

    nice one mate. cheers!

    TYPICAL MICROSOFT!!!

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: