Home > Exchange, Exchange 2010, Microsoft, MS Operating Systems, Office 2010, Office Suite, Outlook 2010, Windows 2008 R2 > Outlook Anywhere not working in Exchange 2010 SP1?

Outlook Anywhere not working in Exchange 2010 SP1?


Had the following a few times now – Outlook Anywhere not working for Exchange 2010 SP1 when the Authentication method is set to Negotiate.

 

Event logs show the following;

 

Process information:
    Process ID: 5200
    Process name: w3wp.exe
    Account name: IIS APPPOOL\DefaultAppPool
Exception information:
    Exception type: ConfigurationErrorsException
    Exception message: Could not load file or assembly ‘WindowsLiveID, Version=0.0.0.0, Culture=neutral, PublicKeyToken=283dd9fa4b2406c5’ or one of its dependencies. The system cannot find the file specified.

 

In short, change from Negotiate to NTLM as Negotiate introduces the WindowsLiveID provider, and this causes Outlook to fail authentication (in short).

 

If NTLM is already enabled (or Basic) then make sure that the WindowsLiveID provider isn’t being inherited (look in IIS Manager under /RCP in the “Modules” bit Smile

Advertisements
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: