Archive

Archive for the ‘SharePoint’ Category

Sharepoint 2010 bug

September 10, 2010 Leave a comment

http://blogs.architectingconnectedsystems.com/blogs/cjg/archive/2009/12/09/Missing-Server-Side-Dependencies-_2D00_-8d6034c4_2D00_a416_2D00_e535_2D00_281a_2D00_6b714894e1aa.aspx

Excerpt;

Missing Server Side Dependencies – 8d6034c4-a416-e535-281a-6b714894e1aa

So what is this you ask? Well, I did a little digging, I watched the Timer Job and the query it sent ( to the content database of the central admin site):

SELECT tp_WebPartTypeId, COUNT(1), tp_Assembly, tp_Class
FROM AllWebParts (NOLOCK)
WHERE tp_WebPartTypeId IS NOT NULL GROUP BY tp_WebPartTypeId, tp_Assembly, tp_Class

You get back a result set that has a null for the tp_Assembly column for the web part. What is this web part you ask, well it is the Microsoft.Office.Server.Search.WebControls.SearchTopologyView web part in the Microsoft.Office.Server.Search, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c assembly.

If you do a query to see where these 6 instance are:

select *
from AllWebParts
where tp_WebPartTypeId = ‘8D6034C4-A416-E535-281A-6B714894E1AA’

You will see that the web part exists on two pages:

  • SearchAdministration.aspx
  • SearchFarmDashboard.aspx

Open those pages, notice…It DOES exist!

Now, here is the funny thing – rerun the queries. As soon as you open those pages, the databsae gets updated and the error will go away. Weird!!!

Sharepoint 2007 and 2010 “issue”

September 10, 2010 Leave a comment

Not a bug, but never knew this,…

if you have a SharePoint based site that is configured to recycle the application pool it depends on everynight (the default behaviour), the first site access for that app pool will have a 30-120 second delay on it (or more).

This isn’t a “bug” as its simply compiling, caching, etc… on the server after the recycle (or iisreset).

Manual recycles/resets can’t be resolved – however there is a way to “wake up” the site every night after the daily recycle has happened.

http://spwakeup.codeplex.com/

is a little exe that basically “opens” the sites for the first time – it basically becomes the “first user” that suffers the delay. After that, loading times will be rediculously fast 🙂 – schedule this to run each night @ 4/5am and voila – fast intranet at 9am 😛

Restoring a SSP to re-create the Site Admin

April 27, 2009 Leave a comment
Categories: Sharepoint 2007

Moving a Sharepoint SSP Admin Page to a new (or existing) Web Application

April 27, 2009 Leave a comment

Here is exact steps to move SSP Administration site to a new web application

Create a new web application through central admin

Define a new “ssp/admin” manage path for the new web application created for SSP Admin site, ensure the new web application created that will host the new ssp admin site is selected and also specify “explicit inclusion” for type and “ssp/admin” for path, click “Ok”

Create a new site collection using SSP Administration site template

stsadm –o createsite –url http://{replace with your servername}:{replace with port}/ssp/admin -owneremail {owneremail} –ownerlogin {ownerlogin} –sitetemplate OSRV#0 –title “Shared Services Administration {replace with your ssp name}”

edit the ssp to point to the new ssp administration site

Stsadm –o editssp –title “{replace with your ssp name” –sspadminsite “http://{replace with your server name}:{replace with port}/ssp/admin”

 

(from http://blogs.msdn.com/ramg/archive/2008/07/01/moving-ssp-admin-site.aspx)

Categories: Sharepoint 2007